I read your reasons for not moving expo to the newest version of React. I think you should support 0.56.0 for two main reasons. First of all, with Babel7 now officially released, expo is increasingly more difficult to use with modules moving to Babel7. Secondly, as the react community moves forward, expo is stuck in the dark ages.

https://blog.expo.io/expo-sdk-v29-0-0-is-now-available-f001d77fadf